Resolved
The issue affecting our latest Windows package has been fully resolved. The package is now signed correctly and has been re-released. All systems are now operating normally, and we will continue to monitor to ensure stability.
Investigating
We are currently investigating reports of an issue affecting our latest Windows packages which are missing signatures & are getting blocked by Windows Defender. Our team is working to determine the root cause and will provide an update as soon as more information is available.