Login page unavailable for certain users
Resolved·Partial outage

The issue affecting the login page has been fully resolved. All systems are now operating normally, and we will continue to monitor to ensure stability.

Wed, Nov 19, 2025, 01:31 AM
(2 weeks ago)
·
Affected components
User authentication Service
Updates

Resolved

The issue affecting the login page has been fully resolved. All systems are now operating normally, and we will continue to monitor to ensure stability.

Wed, Nov 19, 2025, 01:31 AM

Monitoring

We are not seeing any errors from distributed monitoring systems that checks our login page. We will keep this incident open until the underlining infrastructure mark their incident as resolved.

Tue, Nov 18, 2025, 05:46 PM(7 hours earlier)

Monitoring

We have reverted the login domain to login.netbird.io. We continue to monitor the incident and if necessary we might apply the previous workaround.

Tue, Nov 18, 2025, 04:30 PM(1 hour earlier)

Monitoring

We are still using the provider’s URL for authentication, and we continue to observe the recovery of the dependent service. Once it is fully restored, we will revert our login domain to login.netbird.io.

Tue, Nov 18, 2025, 03:33 PM(56 minutes earlier)

Monitoring

A workaround has been implemented for the issue affecting Login service. We’ve removed temporarily our login.netbird.io which relies on Cloudflare’s infrastructure and we are using our provider’s direct domain: https://wiretrustee.eu.auth0.com/ This is temporary measure to allow users to authenticate to their dashboards and peers. We will update you soon.

Tue, Nov 18, 2025, 02:42 PM(51 minutes earlier)

Investigating

We are currently investigating reports of the issue again. Our team is working to determine the root cause and will provide an update as soon as more information is available.

Tue, Nov 18, 2025, 01:20 PM(1 hour earlier)

Monitoring

We have confirmed the relation to the incident with Cloudflare’s outage. The service is recovering and we are monitoring and seeing an increase in availability across different global regions.

Tue, Nov 18, 2025, 12:31 PM(48 minutes earlier)

Investigating

We are investigating reports of timeouts for our login page. Initially it seems to be related to an outage with Cloudflare which is affecting our authentication provider.

Tue, Nov 18, 2025, 11:56 AM(34 minutes earlier)