connection issues for some accounts
Resolved·Degraded performance

Incident Update: Management Service Issue Resolved The issue affecting the management service has been fully resolved by rolling back to the previous version. We’ve identified the root cause and will perform additional testing before deploying an updated version. All systems are now operating normally, and we are continuing to monitor for stability. Details: The issue began shortly after our release at 12:10 PM CEST and impacted some accounts that added new peers. These newly added peers were not correctly included in the network map calculation, which led to inconsistent behavior. We appreciate your patience and will follow up once the new version has passed further validation.

Sat, Nov 1, 2025, 05:46 PM
(1 month ago)
·
Affected components
Management Service
Updates

Resolved

Incident Update: Management Service Issue Resolved The issue affecting the management service has been fully resolved by rolling back to the previous version. We’ve identified the root cause and will perform additional testing before deploying an updated version. All systems are now operating normally, and we are continuing to monitor for stability. Details: The issue began shortly after our release at 12:10 PM CEST and impacted some accounts that added new peers. These newly added peers were not correctly included in the network map calculation, which led to inconsistent behavior. We appreciate your patience and will follow up once the new version has passed further validation.

Sat, Nov 1, 2025, 05:46 PM

Identified

After the release of a new version some accounts noticed connection issues between some peers due to issues updating the network map. This issue affected some accounts adding new peers to their accounts.

Sat, Nov 1, 2025, 05:38 PM